[Solved] WARN[0000] /opt/yams/docker-compose.yaml: `version` is obsolete

Having any issues installing YAMS? This is the place to ask!
Post Reply
Tomwaste
Posts: 9
Joined: Tue May 14, 2024 4:44 am
United States of America

[Solved] WARN[0000] /opt/yams/docker-compose.yaml: `version` is obsolete

Post by Tomwaste »

Hello,

Linux noob here. I keep hitting a wall during install and am not sure how to remedy. It keeps telling me my version of docker-compose is obsolete. Full text below. Any assistance would be appreciated.

Running the server...
This is going to take a while...
WARN[0000] /opt/yams/docker-compose.yaml: version is obsolete
permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get "http://%2Fvar%2Frun%2Fdocker.sock/v1.45/containers/json?all=1&filters=%7B%22label%22%3A%7B%22com.docker.compose.config-hash%22%3Atrue%2C%22com.docker.compose.project%3Dyams%22%3Atrue%7D%7D": dial unix /var/run/docker.sock: connect: permission denied

User avatar
rogs
Site Admin
Posts: 131
Joined: Mon Oct 23, 2023 12:53 pm
Location: Montevideo, Uruguay
Gender:
Contact:
Uruguay

Re: WARN[0000] /opt/yams/docker-compose.yaml: `version` is obsolete

Post by rogs »

Hey @Tomwaste!

It looks like you can't run docker without sudo. Check this: https://yams.media/faqs/common-errors/#docker

Cheers!

Roger.

YAMS Creator

E: roger (at) rogs.me. Fuck you, email bots.
W: https://rogs.me
gpg: curl -sL https://rogs.me/rogs.txt | gpg --import
fingerprint: ADDF BCB7 8B86 8D93 FC4E 3224 C7EC E9C6 C36E C2E6


Also, I love cats :mrgreen:

Pirate jet, pirate jet
Tomwaste
Posts: 9
Joined: Tue May 14, 2024 4:44 am
United States of America

Re: WARN[0000] /opt/yams/docker-compose.yaml: `version` is obsolete

Post by Tomwaste »

Thanks! Hmm. Still hitting the same wall. I logged out and back in. I also made sure to user was part of the docker group. Still getting the same error.

User avatar
rogs
Site Admin
Posts: 131
Joined: Mon Oct 23, 2023 12:53 pm
Location: Montevideo, Uruguay
Gender:
Contact:
Uruguay

Re: WARN[0000] /opt/yams/docker-compose.yaml: `version` is obsolete

Post by rogs »

Can you run docker run hello-world without sudo? How did you install Docker? What OS are you using?

YAMS Creator

E: roger (at) rogs.me. Fuck you, email bots.
W: https://rogs.me
gpg: curl -sL https://rogs.me/rogs.txt | gpg --import
fingerprint: ADDF BCB7 8B86 8D93 FC4E 3224 C7EC E9C6 C36E C2E6


Also, I love cats :mrgreen:

Pirate jet, pirate jet
Tomwaste
Posts: 9
Joined: Tue May 14, 2024 4:44 am
United States of America

Re: WARN[0000] /opt/yams/docker-compose.yaml: `version` is obsolete

Post by Tomwaste »

No, can't run it from the server. I'm using Linux Mint. It's a new instance installed specifically for this project. The script was unable to add Docker and Docker-Compose (I can't recall the error) so installed them both via sudo apt.

User avatar
rogs
Site Admin
Posts: 131
Joined: Mon Oct 23, 2023 12:53 pm
Location: Montevideo, Uruguay
Gender:
Contact:
Uruguay

Re: WARN[0000] /opt/yams/docker-compose.yaml: `version` is obsolete

Post by rogs »

I'm sorry, but I haven't tested if YAMS works on Linux Mint. The install instructions suggest you use either Debian server or Ubuntu Server 22.04

https://yams.media/install/steps/#dependencies

YAMS Creator

E: roger (at) rogs.me. Fuck you, email bots.
W: https://rogs.me
gpg: curl -sL https://rogs.me/rogs.txt | gpg --import
fingerprint: ADDF BCB7 8B86 8D93 FC4E 3224 C7EC E9C6 C36E C2E6


Also, I love cats :mrgreen:

Pirate jet, pirate jet
Tomwaste
Posts: 9
Joined: Tue May 14, 2024 4:44 am
United States of America

Re: WARN[0000] /opt/yams/docker-compose.yaml: `version` is obsolete

Post by Tomwaste »

Ah, my bad. I assumed that since Mint was built on Ubuntu it would be fine. I'll just try with Ubuntu. Thanks for your help.

User avatar
rogs
Site Admin
Posts: 131
Joined: Mon Oct 23, 2023 12:53 pm
Location: Montevideo, Uruguay
Gender:
Contact:
Uruguay

Re: WARN[0000] /opt/yams/docker-compose.yaml: `version` is obsolete

Post by rogs »

No worries! I'm not sure if it works in Mint to be honest, it would be great to have the error message from the docker installation (I'm guessing there's a mismatch on the repositories).

Also, you never answered if you could run docker run hello-world, your issue might be that Docker is not installed correctly. I don't know what version of Docker Mint installs by default, so knowing if you can run docker run hello-world would be very beneficial :D

YAMS Creator

E: roger (at) rogs.me. Fuck you, email bots.
W: https://rogs.me
gpg: curl -sL https://rogs.me/rogs.txt | gpg --import
fingerprint: ADDF BCB7 8B86 8D93 FC4E 3224 C7EC E9C6 C36E C2E6


Also, I love cats :mrgreen:

Pirate jet, pirate jet
Tomwaste
Posts: 9
Joined: Tue May 14, 2024 4:44 am
United States of America

Re: WARN[0000] /opt/yams/docker-compose.yaml: `version` is obsolete

Post by Tomwaste »

Aw, I'm sorry. I wiped that computer and installed Ubuntu before I saw this. It went smoothly! I did run hello-world for Docker when I was using Mint and it did work. If I remember correctly, the script was able to install Docker but not Docker-Compose. And after I installed it myself the script failed to recognize it for some time. I don't remember how I fixed that (or if it didn't just fix itself somehow). Like I said, I'm a newbie. I got no idea what I'm doing. I really appreciate your help on this. I might have spent a couple more days banging my head against the wall before figuring out it was because of the OS.

User avatar
rogs
Site Admin
Posts: 131
Joined: Mon Oct 23, 2023 12:53 pm
Location: Montevideo, Uruguay
Gender:
Contact:
Uruguay

Re: WARN[0000] /opt/yams/docker-compose.yaml: `version` is obsolete

Post by rogs »

Amazing! I'm glad it worked :D I'm marking it as fixed.

I'll always ask questions here, but you can also join our Discord or Matrix server and get or share tips with the people over there!

YAMS Creator

E: roger (at) rogs.me. Fuck you, email bots.
W: https://rogs.me
gpg: curl -sL https://rogs.me/rogs.txt | gpg --import
fingerprint: ADDF BCB7 8B86 8D93 FC4E 3224 C7EC E9C6 C36E C2E6


Also, I love cats :mrgreen:

Pirate jet, pirate jet
Post Reply