[Solved] Permissions Error While Installing

Having any issues installing YAMS? This is the place to ask!
Post Reply
JayV
Posts: 3
Joined: Sat Oct 28, 2023 4:48 pm
United States of America

[Solved] Permissions Error While Installing

Post by JayV »

I keep getting this error when trying to install YAMS

Code: Select all

Failed to copy docker-compose.custom.yaml to /opt/yams/docker-compose.custom.yaml. Ensure your user (pi) has the necessary permissions

I'm using a Raspberry Pi 4 w/ 4 gbs of RAM running the Raspbian port of Debian 11. I had installed YAMS on this machine once months ago but redid the setup in favor of downloading everything manually and using OMV to send everything from my laptop to the Pi. I've been wanting to re-automate everything so I wiped my entire Pi and harddrive in hopes of getting YAMS set up again, but I've been having this issue nonstop. I've made sure that all of the necessary folders are owned by the Pi user and have full 777 permissions.

Code: Select all

pi@pi:/opt $ ls -l
total 8
drwxrwxrwx 4 pi pi 4096 Oct 28 11:37 containerd
drwxrwxrwx 4 pi pi 4096 Oct 28 12:46 yams

Any help would be super appreciated since this is driving me nuts lol

User avatar
rogs
Site Admin
Posts: 131
Joined: Mon Oct 23, 2023 12:53 pm
Location: Montevideo, Uruguay
Gender:
Contact:
Uruguay

Re: Permissions Error While Installing

Post by rogs »

Hey!

The error looks pretty self explanatory. Does your user (pi) has permissions to write on the installation directory?

Did you run this? https://yams.media/install/steps/#setup ... r-location

Code: Select all

sudo mkdir -p /opt/yams
sudo chown -R $USER:$USER /opt/yams

Also, can you send an ls -la for the contents of the /opt/yams directory?

Code: Select all

ls -la /opt/yams
YAMS Creator

E: roger (at) rogs.me. Fuck you, email bots.
W: https://rogs.me
gpg: curl -sL https://rogs.me/rogs.txt | gpg --import
fingerprint: ADDF BCB7 8B86 8D93 FC4E 3224 C7EC E9C6 C36E C2E6


Also, I love cats :mrgreen:

Pirate jet, pirate jet
JayV
Posts: 3
Joined: Sat Oct 28, 2023 4:48 pm
United States of America

Re: Permissions Error While Installing

Post by JayV »

Tried running those 2 lines and still getting the same errors :/ I thought at first that maybe messing with chmod could be causing it but that's wasn't the case. I tried a fresh install only really adding an external hard drive as a permanent mount and still got those errors. This is what I get from ls -la

Code: Select all

pi@pi:~ $ ls -la /opt/yams
total 100
drwxrwxrwx 4 pi pi  4096 Oct 28 12:46 .
drwxrwxrwx 4 pi pi  4096 Oct 28 12:44 ..
drwxrwxrwx 2 pi pi  4096 Oct 28 12:44 base
-rwxrwxrwx 1 pi pi    61 Oct 28 12:44 docker-compose.custom.yaml
-rwxrwxrwx 1 pi pi  4890 Oct 28 12:44 docker-compose.example.yaml
-rwxrwxrwx 1 pi pi  4890 Oct 28 15:19 docker-compose.yaml
-rwxrwxrwx 1 pi pi   901 Oct 28 12:44 docker.sh
-rwxrwxrwx 1 pi pi 17964 Oct 28 12:44 docs.org
-rwxrwxrwx 1 pi pi   277 Oct 28 15:19 .env
-rwxrwxrwx 1 pi pi   277 Oct 28 12:44 .env.example
drwxrwxrwx 8 pi pi  4096 Oct 28 12:44 .git
-rwxrwxrwx 1 pi pi    48 Oct 28 12:44 .gitignore
-rwxrwxrwx 1 pi pi 12301 Oct 28 12:44 install.sh
-rwxrwxrwx 1 pi pi  7867 Oct 28 12:44 README.org
-rwxrwxrwx 1 pi pi  3673 Oct 28 12:44 yams
User avatar
rogs
Site Admin
Posts: 131
Joined: Mon Oct 23, 2023 12:53 pm
Location: Montevideo, Uruguay
Gender:
Contact:
Uruguay

Re: Permissions Error While Installing

Post by rogs »

I see what's the problem now.

You cloned YAMS's repository in /opt/yams, but that's not correct. Your clone location and your install location must be different!

Try this now:

Code: Select all

 # Remove the old directory and all the bad permissions
sudo rm -rf /opt/yams/

# Create the directory again with the correct permissions
sudo mkdir /opt/yams
sudo chown -R $USER:$USER /opt/yams

# Clone YAMS again to your home folder
git clone https://gitlab.com/rogs/yams.git ~/yams
cd ~/yams

# Run the YAMS installer
bash install.sh

I'll make some changes in the website to make more clear that your git clone can't be inside the install location for YAMS.

It should work now!

Edit:

I just improved the installation instructions to make the clone location more specific. You can see the change here: https://yams.media/install/steps/#cloning-from-gitlab

Image

Thank you for the feedback!

YAMS Creator

E: roger (at) rogs.me. Fuck you, email bots.
W: https://rogs.me
gpg: curl -sL https://rogs.me/rogs.txt | gpg --import
fingerprint: ADDF BCB7 8B86 8D93 FC4E 3224 C7EC E9C6 C36E C2E6


Also, I love cats :mrgreen:

Pirate jet, pirate jet
JayV
Posts: 3
Joined: Sat Oct 28, 2023 4:48 pm
United States of America

Re: Permissions Error While Installing

Post by JayV »

Oh my god it worked god bless!!! Now time to figure out how to get an SMB file share server onto the same folder as my media for if I gotta download things manually on my main laptop lol :lol:

User avatar
rogs
Site Admin
Posts: 131
Joined: Mon Oct 23, 2023 12:53 pm
Location: Montevideo, Uruguay
Gender:
Contact:
Uruguay

Re: Permissions Error While Installing

Post by rogs »

Excellent! That's good news :D

I'm glad you where able to fix the issues. And again, thank you for the feedback! Things like this help us improve the documentation!

If you have any other issues, just let us know!

YAMS Creator

E: roger (at) rogs.me. Fuck you, email bots.
W: https://rogs.me
gpg: curl -sL https://rogs.me/rogs.txt | gpg --import
fingerprint: ADDF BCB7 8B86 8D93 FC4E 3224 C7EC E9C6 C36E C2E6


Also, I love cats :mrgreen:

Pirate jet, pirate jet
Post Reply